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SYMPTOMS

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Requested by: Suvradip Roy   

When user is trying to import excel file in Ginesys web, an error message is showing - "HTTP Error 503. The service is unavailable".

CAUSE

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The probable cause for the above issue is server is temporarily unavailable. If the issue persists we might notice the following error in Event Viewer logs.

Event ID 10016
“The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID {D63B10C5-BB46-4990-A94F-E40B9D520160} and APPID {9CA88EE3-ACB7-47C8-AFC4-AB702511C276} to the user IIS APPPOOL\GINESYSAppPoolFx4 SID (S-1-5-82-1358216942-634677025-1763237028-1288803088-3211383273) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.”

RESOLUTION

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Follow the given steps to resolve the issue:

You need to provide administrative privileges to the two registry keys - CLSID & APPID. Also need to configure the DCOM Configuration in Component Services to provide “Local Activation” permission to the users/groups of the registry keys.

This long process could be implemented quickly by running a script in Windows Powershell.

Please check the following links:
https://hinchley.net/articles/changing-dcom-security-permissions-with-powershell/

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take-back 'AppID\RuntimeBroker.exe'

This should resolve your issue, in case you face it again please contact our Ginesys Care portal - https://care.ginesys.in/ 


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