SYMPTOMS
In Ginesys Report module, while trying to run any report from Home tab , an error message appeared on screen.
Error: The requested name is valid, but no data of the requested type was found
Server stack trace:
at System.Net.Dns.GetAddrInfo(String name)
at System.Net.Dns.InternalGetHostByName(String hostName, Boolean includeIPv6)
at System.Net.Dns.GetHostAddresses(String hostNameOrAddress)
at System.Runtime.Remoting.Channels.RemoteConnection.CreateNewSocket()
at System.Runtime.Remoting.Channels.SocketCache.GetSocket(String machinePortAndSid, Boolean openNew)
at System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink.SendRequestWithRetry(IMessage msg, ITransportHeaders requestHeaders, Stream requestStream)
at System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink.ProcessMessage(IMessage msg, ITransportHeaders requestHeaders, Stream requestStream, ITransportHeaders& responseHeaders, Stream& responseStream)
at System.Runtime.Remoting.Channels.BinaryClientFormatterSink.SyncProcessMessage(IMessage msg)
Screenshot of Error Message :
Further Observation : In this two cases this error may occurred.
Web Reports server is migrated to other system.
Web Reports re-installed in same server.
CAUSE
Schedule Remoting Host path details is wrong ( protocol or hostname/IP ) under Scheduler Settings of Server tab.
RESOLUTION
Set the Schedule Remoting Host path details properly with current report server details (Protocol, Hostname or IP,Port).
Then save the settings and click on Apply.
Add Comment