Problem
In Ginesys Report module, while trying to run any report from Home tab , an error appeared as follows.
Error: The requested name is valid, but no data of the requested type was found
Server stack trace:
at System.Net.Dns.GetAddrInfo(String name)
at System.Net.Dns.InternalGetHostByName(String hostName, Boolean includeIPv6)
at System.Net.Dns.GetHostAddresses(String hostNameOrAddress)
at System.Runtime.Remoting.Channels.RemoteConnection.CreateNewSocket()
at System.Runtime.Remoting.Channels.SocketCache.GetSocket(String machinePortAndSid, Boolean openNew)
at System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink.SendRequestWithRetry(IMessage msg, ITransportHeaders requestHeaders, Stream requestStream)
at System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink.ProcessMessage(IMessage msg, ITransportHeaders requestHeaders, Stream requestStream, ITransportHeaders& responseHeaders, Stream& responseStream)
at System.Runtime.Remoting.Channels.BinaryClientFormatterSink.SyncProcessMessage(IMessage msg)
Screenshot of the Error Message :
Further Observation :
Entire Server reinstalled and Web report also re-installed with the help of Ginesys Report folder.
Entire Server migrated to another system and web report also re-installed with Ginesys Report folder.
CAUSE
Schedule Remoting Host path details is wrong ( protocol or hostname/IP ) under Scheduler Settings of Server tab.
Resolution
Set the Schedule Remoting Host path details properly with running report server configuration (Protocol, Hostname or IP,Port).
Then save the settings and click on Apply.
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