SYMPTOMS
Database backup cannot be taken in GINESYS HO. The following error message is being generated.
"Unable to generate license information. Data backup operation aborted"
. Neither the .bak file nor the .dmp file is getting created.
CAUSE
One of the causes for the error message to be shown is the presence of an unregistered/wrong version of GinFileSystem.dll. A look at the Runtime logs may show the following error - Unable to generate Licence backup due to OLE error.
RESOLUTION
A probable resolution of this issue might be achieved by following the given steps:
- Go to
C:\Program Files\Common Files\Ginesys Shared
- Check if GinFileSystem.dll is present in the above folder.
- If it is present, type cmd in your Windows search box and open the command prompt.
- Now run the following command at the prompt, Regsrv32 \Program Files\Common Files\GINESYS Shared -u to unregister the GinFileSystem.dll
- Now to register the correct version of the GinFileSystem.dll run the following command at the command prompt, Regsrv32 ...\Program Files (x86)\Common Files\GINESYS Shared\GinFileSystem.Dll
- Attempt to take a manual backup.
- Backup should be successful.
If you still face the same issue, please log a ticket with GINESYS Helpdesk at support.ginesys.in
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an unregistered/wrong version of GinFileSystem.dll
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