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"GINESYS Report engine not yet configured. Please get in touch with your Administrator or call GINESYS Helpdesk."-Error while opening the Ginesys Report.

SYMTOMS


While clicking on Report menu a message appeared in the Repository tab or in Home tab or in Server tab as follows.

GINESYS Report engine not yet configured.Please get in touch with your Administrator or call GINESYS Helpdesk.

 

 

 

Along with that if we click on Sync button on Repository page same kind of message appears into Error Message box.

 

 

 

CAUSE


In this article we have described the known causes of this kind of error message as case specific.

Case 1: GINESYS Report Application is either not installed or not properly configured in your system.

Case 2: Particular entries are missing in Ginapp.config file for Ginesys Report configuration but Ginesys Report is already installed in your system.

Case 3: In IIS server manager, Site Binding settings of Default Web Site restricts the Report working procedure.

Case 4: SSL certificate installation for HTTPS environment settings, is also one of the reason for the above error.

Case 5: Some Unknown DLL files are present in Bin folder of ReportUI & ReportAPI, might be a reason.

RESOLUTION


Solutions are provided with the basis of the above mentioned cases serially.

Solution for Case 1:

We have to install Ginesys Report application properly . For Ginesys Report Installation we can follow the article https://ginesys.atlassian.net/wiki/spaces/PUB/pages/53477456

Solution for Case 2:

It is highly recommended that always take backup of Ginapps.config xml file before making modification or an improper change in Ginapps.config.xml file causes a serious problem. We can revert back file if any problem occurs.

Here we have to open Ginapps.config file from the path \GSL\GINESYS12\Shared\ and search for the tag <appSettings file=""> and then add the below two entry into this tag and save the Ginapps.config file.

<add key="ReportURI" value="/GinesysReportUI/" /> <add key="CustomPort" value="" />

An example after adding the entries into the tag as follows :

<appSettings file=""> <add key="ReportURI" value="/GinesysReportUI/" /> <add key="CustomPort" value="" /> </appSettings>

Solution for Case 3 :

  1. First open the IIS server manager console and Click on Default Web Site , at left hand side , we can see the Bindings Option ,

  2. Click on Bindings & a Site Bindings window will open and we can see some entries there .

  3. Then find the column Type and into that column we can see the Http entry.

  4. Double Click on Http entry and a small window will open.

  5. Remove Host name field & Set the IP Address field as “All Unassigned“ then click on OK.

An example of modified settings given below.

Solution for Case 4:

  1. First open the IIS server manager console and Click on Default Web Site ,

  2. At left hand side , we can see the Bindings Option , click on Bindings & a Site Bindings window will open and we can see some entries .

  3. Then find the column Type and into that column we can see the Https entry.

  4. Double Click on Https entry and a small window will open. If we see any certificate in SSL certificate field then we can follow the below article for solution.

https://ginesys.atlassian.net/wiki/spaces/PUB/pages/1703608477

A sample of https site binding settings.

Solution for Case 5 :

In this case, first we have to understand from which bin folder the problem occurs. So we try to browse below links one by one manually.

  • In Web Browser open ReportUI page manually using the URL : http://<localhost or Hostname of report Server>/GinesysReportUI/Admin.aspx

  • In Web Browser open ReportAPI page manually using URL : http://<localhost or Hostname of report server>/GinesysReportAPI/Api.asmx

Those pages will help us to find out Wrong DLL files. Then go to the following path & remove files from respective bin folder location as per the above understanding.

  1. \GinesysReport\ReportUI\Bin\

  2. \GinesysReport\ReportAPI\Bin\

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