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"Could not connect to Ginesys Database. Please check the Database setting from GINESYS."--Error while run the Import Excel option from Ginesys Desktop Application.

SYMPTOMS


Error occurs while trying to open the Data Import Utility from Desktop Application in every module. The error message appears on screen as follows.

GINESYS Data Import

Could not connect to GINESYS database. Please check the database setting from GINESYS.

CAUSE


  • One of the main reason of this problem is Data Import Utility is unable to connect with the HO Database.

Areas to look into :

  1. Need to check Database connection with IP address instead of HO Database server host-name.

  2. Need to check ODAC64 installation path in Windows Registry.

  3. Inbound call to Oracle Database is blocking or not by any Anti Virus application & Firewall.

RESOLUTION


  • Set IP address of HO Database server in DatabaseLocator.exe Utility. Then Test Database connection and save it.

  • If Database connection is already set with IP address. Then follow below steps.

  1. Verify the ODAC64 installation location in Windows Registry. If require freshly re-install the ODAC64 bit version.

Always export the ODAC64 registry value and save properly before making any changes during ODAC64 re-installation or Un-installation.

2. Add Oracle Database Server Port (Ex: 1521 ) to the exclusion list of Firewall & Antivirus Application.