Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

SYMPTOMS

...

In Ginesys Report module , there is an option to schedule reports. But sometimes user may encounter report scheduling related problem. In this article we will discuss the common known causes & its solutionresolution.**

CAUSES

...

The known causes for this type of issue are listed below.

  • The eWebReportsScheduler.xmlfile is missing in the report scheduler folder in the following path <Ginesys Report Insallation drive>\GinesysReport\ReportScheduler\.

  • Some incomplete tag may exists in eWebReportsScheduler.xml file.

  • The main executable file i.e eWebReportsScheduler.exe is missing in the following path <Ginesys Report Insallation drive>\GinesysReport\ReportScheduler\.

  • It may be one of the reason that eWebReportsScheduler.exe is blocked for execution due to security authentication reasonWindows security service (SmartScreen Filter).

  • Another reason could be the eWebReportsScheduler_ReportScheduler service is not getting start started or stop stopped normally.

RESOLUTION

...

1. Find & place the proper eWebReportsScheduler.xml file to the following path <Ginesys Report Insallation drive>\GinesysReport\ReportScheduler\.

2. Search for any incomplete tag is present or not in eWebReportsScheduler.xml file using starting <> , ending tag </> & if you found complete those tags properly.

3. If the eWebReportsScheduler.exe is found missing , then you have to download the report kit as per version from below link & post the extract after extracting the folder and find eWebReportsScheduler.exe from the path <Ginesys Report downloaded drive>\GinesysReport\ReportScheduler\ .

...

  • Ensure that eWebReportsScheduler.xml is available in <GINESYS_Installed_Drive>\GSL\GINESYS12\in the following path  \GinesysReport\ReportScheduler\. 

    In case it is not available, find eWebReportsScheduler<Kit Version>.xml and rename it to eWebReportsScheduler.xml.

  • Open Command Prompt (cmd) with Administrator right. 

  • Run the following commands in command prompt, need to replace the angular brackets with the values specific to particular installation:

  • Code Block
    cd <GINESYS Installed Drive>\GSL\GINESYS12\GinesysReport\
    InstallReportSchedulerService -install <GINESYS Installed Drive>\GSL\GINESYS12\GinesysReport\ReportScheduler

If we wish want to uninstall the Ginesys Report Scheduler service then follow the below steps.

...

Code Block
cd <GINESYS Installed Drive>\GSL\GINESYS12\GinesysReport\
InstallReportSchedulerService -Uninstall <GINESYS Installed Drive>\GSL\GINESYS12\GinesysReport\ReportScheduler

RELATED ARTICLE

...