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Ginesys Web Report Scheduler service is not running or working.
SYMPTOMS
In Ginesys Report module , there is an option to schedule reports. But sometimes user may encounter report scheduling related problem. In this article we will discuss the common known causes & its resolution.
CAUSES
The known causes for this type of issue are listed below.
The
eWebReportsScheduler.xml
file is missing in the report scheduler folder in the following path\GinesysReport\ReportScheduler\
.Some incomplete tag may exists in
eWebReportsScheduler.xml
file.The main executable file i.e
eWebReportsScheduler.exe
is missing in the following path\GinesysReport\ReportScheduler\
.It may be one of the reason that
eWebReportsScheduler.exe
is blocked for execution due to Windows security service (SmartScreen Filter).Another reason could be the
eWebReportsScheduler_ReportScheduler
service is not getting started or stopped normally.
RESOLUTION
1. Find & place the proper eWebReportsScheduler.xml
file to the following path \GinesysReport\ReportScheduler\
.
2. Search for any incomplete tag is present or not in eWebReportsScheduler.xml
file using starting <>
, ending tag </>
& complete those tags properly.
3. If the eWebReportsScheduler.exe
is found missing , then you have to download the report kit as per version from below link & after extracting the folder and find eWebReportsScheduler.exe
from the path <Ginesys Report downloaded drive>\GinesysReport\ReportScheduler\
and replace with the following path \GinesysReport\ReportScheduler\
.
4. If the eWebReportsScheduler.exe
is found blocked then follow the below steps to unblock the required files.
Open CMD with Administrator Rights and run the below command one by one:
C:\Windows\system32>PowerShell ( type & press Enter)
PS C:\Windows\system32> dir <Ginesys Report Installation drive>\GinesysReport\ReportScheduler -Recurse | Unblock -File ( type & press Enter )
PS C:\Windows\system32>
An example is given below.
5. If the Ginesys Report Scheduler service is not getting start or stop properly then re-install service using following steps.
Install the Report Scheduler Windows Service:
Ensure that eWebReportsScheduler.xml is available in the following path
\GinesysReport\ReportScheduler\
.In case it is not available, find eWebReportsScheduler<Kit Version>.xml and rename it to eWebReportsScheduler.xml.
Open Command Prompt (cmd) with Administrator right.
Run the following commands in command prompt, need to replace the angular brackets with the values specific to particular installation:
cd <GINESYS Installed Drive>\GSL\GINESYS12\GinesysReport\InstallReportSchedulerService -install <GINESYS Installed Drive>\GSL\GINESYS12\GinesysReport\ReportScheduler
If we want to uninstall the Ginesys Report Scheduler service then follow the below steps.
Open Command Prompt (cmd) with Administrator right.
Run the following commands in command prompt, need to replace the angular brackets with the values specific to particular installation:
cd <GINESYS Installed Drive>\GSL\GINESYS12\GinesysReport\InstallReportSchedulerService -Uninstall <GINESYS Installed Drive>\GSL\GINESYS12\GinesysReport\ReportScheduler
In case issue still persists then contact at Ginesys Care : https://care.ginesys.in
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