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"Only one connection is allowed in a transaction context if 'Promotable Transaction' attribute is set to 'local' "- Error message is displayed during sync

SYMPTOMS


During sync the following error message is displayed - Only one connection is allowed in a transaction context if "Promotable Transaction" attribute is set to "local"

CAUSE


The problem occurs when a large amount of data, exceeding the default values of Application Transaction Timeout and Command Timeout, are processed while data synchronization between POS site and HO. The application cannot process the data.

RESOLUTION


  1. Press the Windows +R keys together.  (Windows key is the key between the Control(Ctrl) and Alt key on the left hand side of the keyboard.)
  2. At the Run command prompt provide the following path to open Machine.config.

    1. FOR WINDOWS 7 Onwards -
      C:\WINDOWS\Microsoft.NET\Framework64\v2.0.50727\CONFIG\machine.config
  3. In the Machine.config, change the value of AppTransactionTimeout to a very high value like 10hrs.
  4. Paste the following in between Configuration tag.
                               <system.transactions>
                               <machineSettings maxTimeout="00:00:30" />
                               </system.transactions>

FOR GINESYS RETAIL

  1. Right click the GINESYS RETAIL icon on the Desktop.

  2. Click on Properties.

  3. Click on Find Target to open the Retail program list window, find Ginapps.config file.

  4. Under Connection Strings, find the keys CommandTimeout and AppTransactionTimeout.

  5. Change the values of both to a very high number.

  6. In GINESYS RETAIL, change the value of the Status column of the relevant Web Id in the Received or Sent tab from -10 to 20

    1. View received or sent data status in Data Exchange.

    2. Right click any record on Receive or Send tab.

    3. Click on Manage Status.

    4. The Manage Data Status window opens.

      Note: The window displays :

      Last Updated On

      Last Update Status

      Last Updated By

    5. Change the status of the data in the Change Status To field and give your allotted password.

  7. Click OK.

This should resolve your issue, in case you face it again please contact our Ginesys Care portal - https://care.ginesys.in/