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SRT (Sales Return) Wizard is getting locked

SYMPTOMS


Requested by: Ranit Jha 09/May/2018 

SRT Wizard is getting locked/hanged with the message shown - 

SRT process is currently in progress at terminal <TERMINAL> by <USER>. Please wait for the process to be complete. 

CAUSE


The SRT Wizard gets locked, if for some reason, one user who was using the SRT Wizard kills the process from Task Manager . Other users whose sessions were thus killed cannot use the SRT Wizard module thereafter.

RESOLUTION


Follow the steps as given to resolve the issue.

  1. Open the database using any of the following tools - TOAD, SQL Plus, SQL Developer.
  2. Log onto the client schema.
  3. In the OPERATION_LOG table - 
    1. Click on the Data button, to see the list of current users of Ginesys HO. 
    2. Delete the record of the source terminal (who has locked SRTWizard) as shown in the error message as "terminal <TERMINAL>" .

SRT Wizard should now work fine.

This should resolve your issue, in case you face it again please contact our Ginesys Care portal - https://care.ginesys.in/