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SYMPTOMS

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The following error message is shown when the user is trying to open Discoverer report (tool) from workstation or VPN connection - "Failed to update system registry, please try using regedit."

CAUSE

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One of the probable causes for the above message to be displayed is that some privileges have not been assigned for the BI tool in the system registry.

RESOLUTION

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There are two possible solutions to the issue:

  1. Add the user to Power Users or Administrator group.
  2. Grant full control privilege of the following registry keys to the Users' group:
    1. HKEY_LOCAL_MACHINE\Software\Oracle
    2. HKEY_LOCAL_MACHINE\Software\Classes
    3. HKEY_LOCAL_MACHINE\Software\Classes\.DIS 
    4. HKEY_LOCAL_MACHINE\Software\Classes\Dis.Document 
    5. HKEY_LOCAL_MACHINE\Software\Classes\Discoverer.Application
    6. HKEY_LOCAL_MACHINE\Software\Classes\DIS 
    7. HKEY_LOCAL_MACHINE\Software\Classes\CLSID
    8. HKEY_LOCAL_MACHINE\Software\Classes\CLSID{470A152C-5FC1-11D1-A434-0000F8AE4944}
    9. HKEY_LOCAL_MACHINE\Software\Classes\CLSID{AD7CE4E0-C391-11CE-9C10-08002BE52B53
  3. Re-open the Discoverer tool.

This should resolve your issue, in case you face it again please contact our Ginesys Care portal - https://care.ginesys.in/ 

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