We’re excited to announce that the latest information is now available on our new site, the
Ginesys One Wiki!. Visit the site for up-to-date resources and insights. We look forward to continuing to support you there!">
We’re excited to announce that the latest information is now available on our new site, the Ginesys One Wiki!. Visit the site for up-to-date resources and insights. We look forward to continuing to support you there!

">

We’re excited to announce that the latest information is now available on our new site, the
Ginesys One Wiki!. Visit the site for up-to-date resources and insights. We look forward to continuing to support you there!">
We’re excited to announce that the latest information is now available on our new site, the Ginesys One Wiki!. Visit the site for up-to-date resources and insights. We look forward to continuing to support you there!

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SYMPTOMS


SMS notification service fails to send SMS despite of having proper SMS configuration and the Ginesys application server has proxy configured in Internet Options to reach Internet. It may also observed, that verification of SMS configuration in SMS Notification utility by sending a test SMS gets succeeded but the scheduled SMS is not being sent vis SMS Notification service. Further, investigating the logs of SMS Notification utility reveals following error message.

Unable to connect to remote Server

In some cases, following error message can be found in log.

Error while sending message. Error details: The operation has timed out

The proxy configuration can be found in Internet Options window. Internet Options either can be opened from searching Windows Search option or from the settings menu of Internet Explorer. To locate the proxy configuration within the Internet Options windows go to the menu Connections > LAN Settings > Proxy Server.

In case the system is configured with a proxy server then the check box against the option 'Use a proxy server for your LAN' is found checked.

CAUSE


SMS Notification service requires an explicit proxy configuration to successfully connect the SMS API. In case the SMS Proxy configuration is not done where the system is accessing Internet via a proxy server.

RESOLUTION


Following simple steps help to configure proxy for SMS Notification utility.

  1. Navigate to Ginesys Shared directory. The path is <Ginesys installed drive>\GSL\GINESYS12\Shared. To open the directory easily, right click on the Ginesys LaunchPad shortcut on desktop and click on 'Open File Location' from right-click menu.

  2. Look for the file SMSProxy.config. Open the file in a text editor. In any case if the file SMSProxy.config is not found in Shared directory, you can save a text file at that location renaming as SMSProxy.config. While saving the text file as .config file, make sure the Save as type is selected as 'All Types (*.*)'

  3. In the text editor, when the file SMSProxy.config is opened it is found empty. In a comma separated way, just type the proxy server IP address and Port as found in Internet Options menu. Make sure, there is only one line present. As an example

    172.16.3.1,8080
  4. Save the file. You can also save oor create the file at any different location, say on Desktop and then copy the file within the Shared directory.

  5. Now validate the configuration by sending a test SMS from the utility UI.

Now the scheduled SMS Notification should work. Same can be tested creating a test event.


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