SYMPTOMS
In Ginesys Report module under Scheduler Settings of Server tab, there is an option Schedule Remoting Host where we can test connection. But sometimes we may face various error message while test the connection. Some common error message appeared on screen are given below.
Error Messages :
Connection to http://192.168.1.140:2001 fails: : Unable to connect to the remote server.
Connection to tcp://192.168.1.141:2001 fails: : Tcp channel protocol violation: expecting preamble.
CAUSES
The probable reasons are :
Report Scheduler service is either not installed or not running.
Connection String entry of Schedule Remoting host is wrong. Wrong entry may be in protocol , Hostname , IP , port etc.
RESOLUTION
First try to run Report Scheduler Service or install the service. For more help you can follow the article.
[Draft]Web Report - Report Scheduler service is not running or working.
If the service is running but still unable to test the connection then you can verify the connection entry.
Protocol should be HTTP or TCP . Protocol is mentioned in a file i.e eWebReportsScheduler.xml from <Ginesys Report_Installed Drive>/GinesysReport/ReportScheduler/.
Hostname should be Report server name or IP address of report Server.
Port always should be 2001.
Standard connection string entry : http or tcp ://hostname or IP of Report server: 2001
An Example given below : http://192.168.1.141:2001
Add Comment