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"An error has occurred while fetching the data" - Error message is shown while item is being downloaded from web.

SYMPTOMS


"An error has occurred while fetching the data.

There was no endpoint listening at http://xxx.xxx.x.xxx/GINESYSService/ItemService.svc that could accept the message." - The error was showing in POS while trying to download an item from the web at the time of billing. 

Important information

Note: < xxx.xxx.xxx.xxx > stand for either the IP address of the HO server or a static IP.

CAUSE


One of the possible causes for the error to be displayed is that the Item service might not be working due to incorrect URL.

RESOLUTION


  1. Go to GINESYS Web > Retail Management > Setup > Master Policy > System Settings
  2. In the Item service field provide the following link - http://xxx.xxx.xxx.xxx/webservice/ItemService.svc where < xxx.xxx.xxx.xxx > stand for either the IP address of the HO server or a static IP.

    Important information

    Note: Check that the URL opens in the browser of both HO and POS. In case any error message is displayed, please contact your Network Administrator.

  3. Save the changes and then sync them to the stores.
  4. Sync from the stores to update the master policy.
  5. Log out of the POS software and login again for the policy to take effect.

Now there should be no issues in the download of the items at the POS end.

This should resolve your issue, in case you face it again please contact our Ginesys Care portal - https://care.ginesys.in/  


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