"The conversion of a varchar data type to datetime data type resulted in an out-of-range value" - Error message is being displayed while sync and/or settlement
SYMPTOMS
The following error message may be shown during Sync - "The conversion of a varchar data type to datetime data type resulted in an out-of-range value"
and Sync and Settlement fail.
CAUSE
One of the reasons for the above issue might be an incorrect registry setting. Follow the below mentioned steps to correct the registry.
RESOLUTION
STEPS | FIGURE |
---|---|
Type Regedit in your Search window to open the Registry Editor | |
Follow the given path - HKEY CURRENT USER > CONTROL PANEL > INTERNATIONAL > sTime | |
Double click on the field sTime and change the value. The sTime field in registry has to be updated with ( : ) without the brackets (). Click on OK and close the Registry Editor. Run Data Sync manually and settle your POS documents. |
This should resolve your issue, in case you face it again please contact our Ginesys Care portal - https://care.ginesys.in/