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Scheduler service is installed in more than one terminal - Error message is shown when user tries to open POS

SYMPTOMS


When the user tries to run Ginesys POS, the system shows the message - Scheduler service is installed in more than one terminal.

CAUSE


The causes of this scenario are usually one of the following:

  • A former Ginesys POS Application Server has been discarded and a new Ginesys POS Application Server has been set up. But the application can still detect the presence of the former Ginesys POS Application Server in its database.
  • A former Ginesys POS Application Server has been formatted and its machine name has changed. But the application can still detect the presence of the former Ginesys POS Application Server in its database.
  • A former Ginesys POS Application Server gets re-connected to the same network after an existing and running Ginesys POS Application Server has been installed.

In all the above cases, a Ginesys POS Application Server is moved to a new machine either due to hardware upgrade or software issues. Since the same local database contains references to both application servers, a database lock-down occurs and the error message is displayed as both machines simultaneously expose themselves as Ginesys POS Application Servers. Now, if the old application server is still connected to the same network then you need to demote the old system from application server role from the old system itself and if the old system is not present physically then you need to clear the database lock only.


RESOLUTION


Multiple Ginesys POS Application Server issue can be handled by following the steps given below:

  1. Ensure that you are connected from the machine which is incorrectly exposing itself as the server.

  2. Right click on the POS icon and select Open file location. GINESYS POS window opens.

  3. Search for the DatabaseLocator.exe (Utility Application).

  4. Right click on the DatabaseLocator application file and select Run as Administrator. Local Database Locator and Tools window opens.

  5. In the Utilities tab, click on Demote this Machine From Application Server. A message will appear - "This option will uninstall the data sync service from the machine and demote this machine from GINESYS POS Application server role. Are you want to proceed?" If you click on Yes the system will be demoted the server from database. This will uninstall the Scheduler Service but it will still be marked as a Ginesys POS Application Server in the database. 

  6. In the Utilities tab, click on Clear Obsolete Application Servers.... 

  7. In Clear Obsolete Ginesys Application POS Servers window, select the machine you demoted from server in the previous Step 5.

  8. Click on Demote. This will remove the demoted machine's identification as a server from the database.

  9. Now click on Close to close the window.

  10. Start your Ginesys POS Application as usual.

    If the former application server has been formatted and Renamed but the reference of it still lies in the database, you need to follow the Step 6 through Step 10.