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"Could not load file to assembly..... or one of its dependencies. The system cannot find the file specified"- Error message is shown on Ginesys POS Application login

SYMPTOMS


Created based on the information provided by Arindam Banerjee  

"Could not load file to assembly 'NPOS.LicenseService Version 1.0.0.0, Culture=neutral, PublicKeyTocken=null, or one of its dependencies. The system cannot find the file specified" - Error message is shown while user is trying to login into Ginesys POS Application.

CAUSE


A probable reason for the error is the local antivirus in the POS Server, especially Windows Defender or Microsoft Security Essential has removed or quarantined a Ginesys POS Application file (NPOS.LicenseService.exe)This behavior is detected where the Microsoft Threat Definition has recently got updated.

You can ensure the above as the cause if you find the above mentioned Ginesys POS Application file in quarantined list in antivirus history. 

RESOLUTION


You are requested to executed the following steps:

  1. Add POS locations to Antivirus Exclusion List.

    1. Following article from Microsoft may help you to do this.
        https://support.microsoft.com/en-us/help/4028485/windows-10-add-an-exclusion-to-windows-security

  2. The POS folders also have to be added to the Antivirus Exclusion List 
    The POS folders are located in: <Ginesys POS installation drive>:\ProgramData\GINESYS>

  3. Restore the file from antivirus's quarantined list. Following article from Microsoft may help you to do this.
    https://docs.microsoft.com/en-us/windows/security/threat-protection/windows-defender-antivirus/restore-quarantined-files-windows-defender-antivirus

    Tip

    If you are unable to open any link directly, please copy and paste the link in your web browser.

    If you are unable perform the above operation, then update the POS from the Auto Updater.

  4. Restart the 'Ginesys POS Licensing Service' from Windows Services (services.msc).

  5. If in any case 'Ginesys POS Licensing Service' is not found in services list, please install License Service from DatabaseLocator.exe utility.

  6. After installation start the 'Ginesys POS Licensing Service'.

The above steps should resolve your issue. In case you face it again please contact our Ginesys Care portal - https://care.ginesys.in/