mO SharemO Share

"There is no row at position 0."-Error While trying to open POS.

SYMPTOMS


While trying to open Ginesys POS application , an error message appears on Screen as follows

 

Error log details shown below:

16-Aug-2019 01.31.21 PM> Custom Patch query: SELECT * FROM v_CustomType WHERE Active = 1 AND Applications 16-Aug-2019 04:00:00 PM> FlatFileLogger Instance Id: 12611187.
16-Aug-2019 04:00:00 PM> Sync is running from 'Child'.
16-Aug-2019 04:00:00 PM> Data Exchange job (Sync) instance HashCode = 39774547
16-Aug-2019 04:00:00 PM> Data Exchange job fired from Service automatically from 'xxxx-PC' machine at 16-08-2019 04:00:00 PM
16-Aug-2019 04:00:00 PM> Creating necessary objects for Data Exchange...
16-Aug-2019 04:00:00 PM> Select CUID as PeerCUID, StoreName as PeerName, TimeZone from v_Store
16-Aug-2019 04:00:00 PM> SELECT CP FROM v_SYSInfo
16-Aug-2019 04:00:00 PM> ---------------------------------------------------------------------------
16-Aug-2019 04:00:00 PM> ERROR:
16-Aug-2019 04:00:00 PM> ---------------------------------------------------------------------------
16-Aug-2019 04:00:00 PM> Message: There is no row at position 0.
16-Aug-2019 04:00:00 PM> Source: System.Data
16-Aug-2019 04:00:00 PM> Target Site: NodePath GetNodeByIndex(Int32)
16-Aug-2019 04:00:00 PM> Stack Trace:
16-Aug-2019 04:00:00 PM > at System.Data.RBTree1.GetNodeByIndex(Int32 userIndex) 16-Aug-2019 04:00:00 PM > at System.Data.RBTree1.get_Item(Int32 index)
16-Aug-2019 04:00:00 PM > at System.Data.DataRowCollection.get_Item(Int32 index)
16-Aug-2019 04:00:00 PM > at Common.DataSync.DataAccess.SQL.DataSyncDataAccess.GetSelfCP_Local()
16-Aug-2019 04:00:00 PM > at Common.DataSync.Business.PeerManagerNPOS.GetBasePeer()
16-Aug-2019 04:00:00 PM > at Common.DataSync.Business.PeerManagerNPOS.get_BasePeer()
16-Aug-2019 04:00:00 PM > at Common.DataSync.Business.Sync.Execute(JobExecutionContext jobContext)
16-Aug-2019 04:00:00 PM> ---------------------------------------------------------------------------
16-Aug-2019 04:00:00 PM> Checking and invoking SYNC COMPLETED event handlers...
16-Aug-2019 04:00:00 PM> SYNC COMPLETED event handler found. Getting event handler...
16-Aug-2019 04:00:00 PM> Invoking SYNC COMPLETED handler...
16-Aug-2019 04:00:00 PM> Refreshing backup information...
16-Aug-2019 04:00:00 PM> Retrieving backup information from database...
16-Aug-2019 04:00:00 PM> select top 1 * from msdb.dbo.backupset where database_name = 'NPOS' AND type = 'D' order by backup_start_date desc
16-Aug-2019 04:00:00 PM> select top 1 * from msdb.dbo.backupset where database_name = 'NPOS' AND type = 'I' order by backup_start_date desc
16-Aug-2019 04:00:00 PM> Backup information retrieved. Start loading...
16-Aug-2019 04:00:00 PM> Last Full backup information NOT FOUND.
16-Aug-2019 04:00:00 PM> Last differential backup information NOT FOUND.
16-Aug-2019 04:00:00 PM> Last full backup start time: Not available
16-Aug-2019 04:00:00 PM> Last full backup end time: Not available
16-Aug-2019 04:00:00 PM> Last differential backup start time: Not available
16-Aug-2019 04:00:00 PM> Last differential backup end time: Not available
16-Aug-2019 04:00:00 PM> Last differential backup location:
16-Aug-2019 04:00:00 PM> Full backup has not been done till now. Exiting differential backup...
16-Aug-2019 04:00:00 PM> SYNC COMPLETED event handling completed.
16-Aug-2019 04:00:00 PM> Sync process completed, flushing buffer.
16-Aug-2019 04:01:00 PM> Unregistering global events...
16-Aug-2019 04:01:00 PM> FlatFileLogger Instance 12611187 is shutting down. Flushing buffer...

CAUSE


  • POS installation is done with wrong POS setup pack ( v 1.30.2 ) .

Observation :

  • SYSinfo table of NPOS database is empty.

RESOLUTION


  • Uninstall the wrong pack and again install POS application with proper POS setup pack.

Current POS pack is 1.146.2

Download Link: http://support.ginesys.in/downloads/current/POS/
Installation Guide: https://ginesys.atlassian.net/wiki/spaces/~5570584eb70e2b10514081a4b0925399f77519/pages/1378418758

RELATED ARTICLE