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"ORA-01017: invalid username/password; logon denied. SYSTEM user connection is ok but SYS user connectivity failed" - Error while connecting HO database

SYMPTOMS


Post creation of an Oracle database for Ginesys HO, Ginesys LaunchPad fails to connect the database. When the database connectivity tested in Database Locator an error appears "ORA-01017: invalid username/password; logon denied. SYSTEM user connection is ok but SYS user connectivity failed...". The complete error message is as follows.

ORA-01017: invalid username/password; logon denied

SYSTEM user connection is ok but SYS user connectivity failed with the same password.

GINESYS requires that SYSTEM and SYS user passwords be same and in same casing. 
This scenario may occur when the SYSTEM password is given in a different case than the one given for SYS user during Oracle installation.

Please give the same password (as of SYS) and in the same case for the connection to succeed.

CAUSE


The error message describes the cause, Ginesys requires same password for Oracle database users SYS and SYSTEM. In Database Locator  Ginesys accepts credential for SYSTEM user only. and it attempts to connect SYS using the same password. In this case the provided password for SYSTEM is correct for SYSTEM user but the same password stands invalid for SYS user. In Oracle the password is case-sensitive by default. So, password may be considered different if the casing of both passwords don't match.

RESOLUTION


The password for both the user SYS and SYSTEM must be set same to resolve this issue. Following steps will help you to do this action.

  1. Open SQLPLUS utility on the database server via command-line or terminal to establish a connection with Oracle database. SQLPLUS version should be displayed. Ensure the SQLPLUS version, for best result, the version should match the Oracle version (10g or 12c) you are using.

    The cursor should blink at 'Enter user-name:' prompt.

  2. Enter SYS user credential in 'Enter user-name:' prompt to connect the database. Replace the placeholder sections with angular brackets (<>) in following command with the correct password and correct database.

    SYS/<Password>@<Database_Name> as SYSDBA

    On successful connection the message 'Connected.' should appear.

    The default for user SYS is 'SYSPWD' if  the Oracle is installed by Ginesys Team and database name is set 'GINESYS'. Use one of the following command in such case

    SYS/SYSPWD@GINESYS as SYSDBA
    or
    SYS/syspwd@GINESYS as SYSDBA

  3. Now first reset the password for user SYSTEM with following command. Replace the placeholder <New_password> with the password you want to set. Keep note of the password for next step.

    alter user SYSTEM identified by <New_password>;


    On successful alteration, the message 'User altered' will appear.

  4. Now reset the password for user SYS with following command. Replace the placeholder <SYSTEM_Password> with the same password you mentioned in previous step. Ensure same casing while mentioning.

    alter user SYS identified by <New_password>;
  5. Now we should verify both login from SQLPLUS. Use following command to test. Replace place holders appropriately.

    To login in SYS user

    connect SYS/<Password>@<Database_Name> as SYSDBA

    To login in SYSTEM user

    connect SYSTEM/<Password>@<Database_Name>

    On successful connection the message 'Connected.' should appear.

    7. If both the connections are successful, them please recheck the database connectivity in Database Locator  with correct password. Click OK to save the credential.

This should resolve the issue. For any difficulty, please contact Ginesys Care team.


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