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"A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond X.X.X.X:80" - Error while trying to open Ginesys Reports.

SYMPTOMS


While accessing Ginesys Report menu in Ginesys Web, following error message appears in Home tab.

A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 192.168.1.139:80 at System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult) at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception)

CAUSE


IP address of the system and the same mentioned in Ginesys Report configuration are different. Generally this happens as the system IP has been changed manually or due to DHCP settings or Ginesys Report configuration file has been replaced.

Further Observation :

Compare the IP of the server and the IP mentioned in Ginesys Report configuration.

  • Get the current system IP address using ipconfig command in Command Prompt.

  • Now check the IP address mentioned in the configuration file GinesysAppConfig.xml in following path <Ginesys Installation Drive>/GSL/GINESYS12/GinesysReport/ReportUI.

Screenshot given below for better understanding of the configuration file.

 

 

 

 

 

 

 

RESOLUTION


  1. Perform SYNC operation from Repository tab of Ginesys Report Module.

  2. Then reset IIS server in Report Server system using IISRESET option in Command Prompt or CMD.

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