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The user is unable to open a web report as the web report module is not available to the user

SYMPTOMS:

The user is unable to open a web report. The web report module is not available to the user.


CAUSE

This happens because when the user is not given the privilege of viewing the web report or creating any web report.


RESOLUTION


A step-by-step guide to resolve this issue:

  • Go to Admin > Security > Users.

  • Select the user and check if he has been assigned the respective role i.e. Power User Report role or Operator.

  • If the Power User report role is not given to the user he will not be able to provide rights to Report roles.

  • Give the power user report role to the user.

  • Now re-login with the User having the Power-user report role.

  • After logging with the power user report role, the user will be allowed to give privilege to the Report role in the below-mentioned process.

  • Open Ginesys Web

  • Go to REPORT Tab.

  • In the Report tab, go to the Server tab.

  • From the server go to the Roles option.

  • From Roles, go to the Main setting

  • Right Click on the Main option and click on Edit.

  • Now give the appropriate privilege to the Role by clicking on the checkbox.

This will give the required permission to the user assigned to that role.