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'Requested quantity of the item is not available.' - Error message displayed incorrectly while scanning items for transaction

SYMPTOMS


While scanning items in POS Bill, Packet,Delivery Slip, Stock Point Transfer etc. from where stock is getting out user is getting restricted with following application error: 'Requested quantity of the item is not available' even if stock of the respective item is available according to the Barcode history report.

 

CAUSE


The real time stock is calculated from the ITEMSTOCK table at POS and it is refreshed as and when any transaction made in the STOCK table. Some times for unknown reason the ITEMSTOCK table is not refreshed after the STOCK table is updated.

RESOLUTION


Please follow below steps..

  1. Open Microsoft SQL Server Management Studio

  2. Open a query editor for NPOS database

  3. Write exec spItemStock_Repopulate and execute.




    Hopefully, this will help you to resolve the issue, if still it is not resolved please contact our Ginesys Tech Team.