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Differential backup is not successful for the last sync. (Session id <>). You need to take a full backup. - Error message is showing and POS is not opening in terminals getting below error

SYMPTOMS


POS is not opening in terminals getting following error - 

Differential backup is not successful for the last sync. (Session id xxxxx). You need to take a full backup.

CAUSE


One of the probable cause is that the shared path is incorrect.

For Example:

There are probably 2-3 drives in the POS server system and POS is installed in one more than 1 drive.

It could be that previously POS was installed in C drive but now client has restored the POS in D drive, but while sharing the path client shared the path for the C drive POS but the POS which is in working is installed in D drive.

RESOLUTION


How to find correct POS server location path

  1. Open Control Panel > Programs & Features
  2. In the Control Panel if location of the installed programs is not showing then right click on the Header and enable the location.
  3. After Enabling the location, you can find the location where Ginesys POS is installed.
  4. In the picture, POS server is installed in D drive.

 

Resolution

  1. Find the correct location where POS server is installed.
  2. Share the folder and provide complete permissions.
  3. Then demap the incorrect shared path in terminal
  4. Re-map the terminal with correct path.
  5. Create the shortcut
  6. Run the NPOS
  7. Now POS will work fine.