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Ginesys Report Scheduler is unable to read the working directory on the client side

SYMPTOMS


Ginesys Report Scheduler is unable to read the working directory on the client side.  When starting / restarting the Ginesys Report Scheduler service, all the previously made schedules are showing blank in the scheduler service window and emails are stuck.

CAUSE


MainSvcThreadFunc throw an exception System.TypeInitializationException: The type initializer for 'WebReports.Api.Scheduler.MainThread' threw an exception. ---> System.InvalidOperationException: Cannot load Counter Name data because an invalid index '' was read from the registry. - Error message is shown when Ginesys Report Scheduler is run.

RESOLUTION


 

Open command prompt with "Run as Administrator".

Go to the C:\windows\system32> lodctr /r

Execute the command by pressing enter.

Message will be displayed - 'Error: Unable to rebuild performance counter setting from system backup store, error code is 2'

Go to the C:\windows\SysWOW64> lodctr /r

Message will be displayed - 'Info: Successfully rebuilt performance counter setting from system backup store'


https://stackoverflow.com/questions/17980178/cannot-load-counter-name-data-because-an-invalid-index-exception