Error: Cannot open report: - Error message is shown when trying to open Report Home
SYMPTOMS
When trying to open Report Home page the following error message is being displayed -
Error:
Cannot open report:
Please contact Ginesys Support Team
CAUSE
There may be multiple causes for the above issue, following causes need to checked in order for analysis -
- No space is available in Hard disk where Ginesys Report is installed.
- Unknown reason - IIS related issue
- Admin page Loading Issues (Localhost/GINESYSReportUI/Admin.aspx)
- .Net 4.7.2 is not installed
RESOLUTION
Case 1: Disk Space issue
- Go to> This PC > Check the Drive space where Ginesys Report is installed.
- Clear the space from Drive.
- Reset IIS (Goto > Run (Run as Administrator) > Type “IISREST”).
- Now login into Web and Open Home.
Case 2: Unknown reason IIS related issue
- Reset IIS (Goto > Run (Run as Administrator) > Type “IISRESET”).
- Now login into Web and Open Home
Case 3: Admin page Loading Issues (Localhost/GINESYSReportUI/Admin.aspx)
It is recommended to verify the Case 1 and Case 2 and if the same issue persists, then follow the Case 3
- Do sync in repository (Take consent of client before sync).
- Open the “Localhost/GINESYSReportUI/Admin.aspx” page but observe it is showing an error message as given below -
Admin Loading Issues
Adding Entity with id 'PROC$LRISUSUM_01' failed because another entity with that id already exists in the collection. Please make sure Entity ids are unique
There is a duplicate Join from 'SRVI Header' to 'SRVI HSN'. This is joining #863 in the configuration - Delete the PROC$LRISUSUM_01
- Now open the report home page.
Case 4: .Net 4.7.2 is not installed
- Download the .Net 4.7.2 from following URL (https://support.ginesys.in/downloads/current/NDP472-KB4054530-x86-x64-AllOS-ENU.exe)
- Install the .Net 4.7.2
- Restart the system and check. Issue should be resolved.
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