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“User not authorised to login. No privileges assigned.” - error message displayed when user tries to login to Ginesys Desktop.

SYMPTOMS


“User not authorized to login. No privileges assigned.” - error message displayed when a particular user tries to login to Ginesys Desktop.

CAUSE


The probable cause of the error message is that the user has not been provided with the required role privilege to login.

RESOLUTION


A probable resolution of this issue might be achieved by following the given steps:

  1. Login to Ginesys Desktop with Admin privilege.

  2. Under Admin module, go to Admin > Security Setting > Role Privileges.

                          

  3. This opens the Security Settings - Role Privileges window.

  4. Click on the Browse button under Criteria.

                     

  5. This opens the Select Role Name… window. Select the desired Role Name. Click OK.

                         

  6. This opens the tree module on the right-hand side.



  7. Right-click on the module name you want to give access to the user to. This will open a permission level box.

                           

  8. Select the appropriate level.

    Note: Assigning rights to the module, automatically assigns rights to all the sub-module within it.

    You can remove the rights of a particular node by double clicking on the checkbox beside it.

    You can also modify the rights of a particular sub-module by selecting and right clicking on it, followed by selecting the desired level of privilege.


  9. If you want to assign rights to that user for other modules, repeat the same process.

  10. Save the changes.

  11. Now try to login once again with the given credentials.

This should resolve your issue, in case you face it again please contact our Ginesys Care portal - https://care.ginesys.in/