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"Backup - Warning, An error occurred while registering types"- Error while trying to take POS backup.

SYMPTOMS


An error occurred while trying to take POS backup the following message appears on screen.

Backup - Warning
---------------------------
An error occured while registering types.
Error while registering NPOS.DataSync.EventHandler.Business.DXPOSReturnHandler, NPOS.DataSync.EventHandler.
Reason:
Value cannot be null.
Parameter name: to
-------------------------

PROBLEM IN AUTOMATIC BACKUP.PLEASE SEE THE LOG FILE.

CAUSE


Probable Cause:

  • POS application files got corrupted. Generally abnormal shutdowns, a faulty hard disk, damaged file-system are among the common causes of file corruption.

RESOLUTION


Reset POS software files using Auto Update utility.

  • Open Auto Update and update the software files from the second tab ‘Update Software’ and ‘Update Dependency Files’. In update dependency section select ‘Download All Files’ checkbox.

 

Further recommendation

Whenever any application issue is encountered where the cause is suspected as file corruption, it is highly recommended that the system must be thoroughly investigated for disk issue or file-system inconsistency. Also, if there was any abnormal shutdown event occurred, the root cause analysis of the abnormal shutdown must be done and prevent any such incident in future. Abnormal shutdown may cause complete or partial damage of running application and further cause business data loss. Following are the basic recommended actions where file corruption is suspected..

  • Check for Critical and Error events logged in Windows Event Viewer related to abnormal shutdown, disk issue and file system issue.

  • Check file system with Chkdsk or any other diagnostic utility.

This should resolve your issue, in case you face it again please contact our Ginesys Care portal - https://care.ginesys.in/ 

 

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