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Ginesys POS Startup Slow from Terminals

SYMPTOMS


GINESYS POS is opening very slow in terminals where internet connection is not present. However, when internet connection is allowed in such a terminal where it is opening slow, startup performance becomes faster.

CAUSE


There can be multiple reasons for slow startup of a GINESYS POS terminal. This checklist will ensure that you have tried to understand the most common reasons for the issue and resolve them. If the issue still persists, please feel free to contact GINESYS support.

RESOLUTION



CHECK 1:

The following setting, if not present in the NPOS.exe.config file, will force the software to connect to the internet for performing some dependent assembly verification. This might cause a slow startup in cases where internet is not allowed in the terminals, e.g. VPN based installations. Adding this setting where internet connection is available but slow may improve the startup performance.

If the following section is not present, then add the following section at the end of NPOS.exe.config file. If the <configuration> section already exists then put the <runtime> section as shown below and if the <configuration> section does not exist then just add the whole section (including <configuration>) mentioned below.

<configuration>
<runtime>
<generatePublisherEvidence enabled="false"/>
</runtime>
</configuration>


CHECK 2:

SQL Server should not run from Dynamic Port. Check if the server is running from the a dynamic port or a fixed port.

It should typically run on fixed port 1433. SQL Server Browser service should be disabled.


CHECK 3: 

Check NPOS database data file size. Despite every configuration setting, if your data size has grown substantially, then you might experience slower performance. This can be addressed to some extent by upgrading your hardware configuration.

To check your SQL Server data and log file size go to the following - 

Open SQL Enterprise Manager > Right Click on NPOS database > Properties > Files > Check file sizes on right pane


CHECK 4: 

If connection is still slow at this point after performing all above UNINSTALL QuickHeal or any other anti virus / firewall solutions from both Server and Terminal and then check performance. We have often observed that improperly configured antivirus and firewall solutions cause performance issues.

IMPORTANT: This step does not imply that GINESYS POS has to run without any antivirus solutions. This step is just to verify whether the performance issue is being caused by the any antivirus / firewall software. If this check is affirmative then install and configure the antivirus / firewall properly. If this check is non-affirmative then just re-install the antivirus / firewall solutions.


CHECK 5: 

Rebuild Indexes from Database Locator > Tools


This should resolve your issue, in case you face it again please contact our Ginesys Care portal - https://care.ginesys.in/