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"Unable to connect to remote server" - Error message appears in SMS Notification utility log as SMS sending fails where internet proxy is configured
SYMPTOMS
SMS notification service fails to send SMS despite of having proper SMS configuration and the Ginesys application server has proxy configured in Internet Options to reach Internet. It may also observed, that verification of SMS configuration in SMS Notification utility by sending a test SMS gets succeeded but the scheduled SMS is not being sent via SMS Notification service. Further, investigating the logs of SMS Notification utility reveals following error message.
Error while sending message. Error details: Unable to connect to the remote server
In some cases, following error message can be found in log.
Error while sending message. Error details: The operation has timed out
The proxy configuration can be found in Internet Options window. Internet Options either can be opened from searching Windows Search option or from the settings menu of Internet Explorer. To locate the proxy configuration within the Internet Options windows go to the menu Connections > LAN Settings > Proxy Server.
In case the system is configured with a proxy server then the check box against the option 'Use a proxy server for your LAN' is found checked.
CAUSE
SMS Notification service requires an explicit proxy configuration to successfully connect the SMS API. In case the SMS Proxy configuration is not done where the system is accessing Internet via a proxy server.
RESOLUTION
Following steps will help you to configure proxy for SMS Notification utility.
Open a text editor.
In the empty text editor mention the proxy details in a comma separated way. You should mention only two information, the proxy server IP address and Port as found in Internet Options menu. Make sure, at anytime there should be only a single line of configuration present.
As an example172.16.3.1,8080
Now save a text file as SMSProxy.config at any easy to locate place, like Desktop. While saving the text file with .config extension, make sure the Save as type is selected as 'All Types (*.*)', else the file will be saved with .txt extension.
Now navigate to Ginesys Shared directory. The path is <Ginesys installed drive>\GSL\GINESYS12\Shared. To open the directory easily, right click on the Ginesys LaunchPad shortcut on desktop and click on 'Open File Location' from right-click menu.
Copy the SMSProxy.config file into Ginesys Shared directory.
Restart the service GINESYS SMS Notification Service to take effect the change. You can restart the service either from Ginesys utility System Manager or Windows service manager Services (services.msc).
Now validate the configuration by sending a test SMS from the utility UI.
Now the scheduled SMS Notification should work. Same can be tested creating a test event.
On a successful configuration, following output can be observed in the log name SMSProcessorJob for every event of SMS, processing, log location: C:\ProgramData\Ginesys\Logs.
25-May-2020 09:26:14 PM> SMS Proxy configuration found...
25-May-2020 09:26:14 PM> Host: 172.16.3.1
25-May-2020 09:26:14 PM> Port: 8080
25-May-2020 09:26:14 PM> SMS Proxy configuration set in request object...
Do not place the file SMSProxy.config in Ginesys Shared directory if there is no proxy server in use. The existence of config file will determines the existence of proxy configuration and the application will always attempt to connect a proxy server, even if the file is empty.